Tagged: avid media composer 7.0 4 system requirements