Tagged: avid media composer 8.4 5 system requirements